Missing ThemeView Engine.cs File

Oct 19, 2013 at 8:23 PM
I install MVC Forum with NuGet Package and configuration on Web.Config and Global.aspx already. Then I run with VS2012 and got error message "ThemeViewEngine.cs Not Found". I think it might be happen because some Dll file is request this class. How I solve this problem. Please help.
Coordinator
Oct 20, 2013 at 2:11 PM
Can you please post the complete stack trace of the error?!
In a running application you would never get an error about a missing .cs file, so I'm guessing you have an error in some view, that would make the Theme Engine fail, and in debug, VS will try getting the file.
Oct 20, 2013 at 4:38 PM
This is image of error after I runing.

Image

Locating source for 'C:\Projects\CreativeMinds\CodePlex\mvcthemes\MVCThemes\ThemeViewEngine.cs'. Checksum: MD5 {4a 81 cf fb 6f f7 57 9e a0 92 4c f4 e4 19 b4 53}
Determining whether the checksum matches for the following locations:
1: D:\Joyce\Portfolio\amatatum.com\MVCForum\MVCForum\Themes\ThemeViewEngine.cs Checksum: MD5 {b6 e6 e3 45 78 2f 58 ea 57 ec f7 58 33 7f ec f2} Checksum doesn't match.
The file 'C:\Projects\CreativeMinds\CodePlex\mvcthemes\MVCThemes\ThemeViewEngine.cs' does not exist.
Looking in script documents for 'C:\Projects\CreativeMinds\CodePlex\mvcthemes\MVCThemes\ThemeViewEngine.cs'...
Looking in the projects for 'C:\Projects\CreativeMinds\CodePlex\mvcthemes\MVCThemes\ThemeViewEngine.cs'.
The file was found in a project: 'd:\joyce\portfolio\amatatum.com\mvcforum\mvcforum\themes\ThemeViewEngine.cs'.
Determining whether the checksum matches for the following locations:
1: d:\joyce\portfolio\amatatum.com\mvcforum\mvcforum\themes\ThemeViewEngine.cs Checksum: MD5 {b6 e6 e3 45 78 2f 58 ea 57 ec f7 58 33 7f ec f2} Checksum doesn't match.
Looking in directory 'C:\Program Files (x86)\Microsoft Visual Studio 11.0\VC\crt\src\'...
Looking in directory 'C:\Program Files (x86)\Microsoft Visual Studio 11.0\VC\crt\src\vccorlib\'...
Looking in directory 'C:\Program Files (x86)\Microsoft Visual Studio 11.0\VC\atlmfc\src\mfc\'...
Looking in directory 'C:\Program Files (x86)\Microsoft Visual Studio 11.0\VC\atlmfc\src\atl\'...
Looking in directory 'C:\Program Files (x86)\Microsoft Visual Studio 11.0\VC\atlmfc\include'...
The debug source files settings for the active solution indicate that the debugger will not ask the user to find the file: C:\Projects\CreativeMinds\CodePlex\mvcthemes\MVCThemes\ThemeViewEngine.cs.
The debugger could not locate the source file 'C:\Projects\CreativeMinds\CodePlex\mvcthemes\MVCThemes\ThemeViewEngine.cs'.
Coordinator
Oct 21, 2013 at 6:07 AM
As expected: "The debugger can not locate..."

This is the error Visual Studio throws because it can't find the file and show you the line where the error occurs, this has nothing to do with the actual error.

Please try running it without the debugger, and tell me what error you get in the browser.
Coordinator
Oct 21, 2013 at 9:22 AM
Did you remove the 2 namespace references from the 2 web.config files in the views folders ?